What killed my PL-660?

Do you have a question about choosing a radio, installing an antenna, or are you simply trying to figure out how to find that elusive station on the dial? This is a place where you can ask your question and seek guidance from a wide variety of radio enthusiasts. No questions are too simple. You will be treated with respect here.
Post Reply
blues dude
Posts: 1
Joined: Wed Jun 08, 2022 5:43 pm

What killed my PL-660?

Post by blues dude »

I've been using a Tecsun PL-660 for about 5 years now, with different antennas. But last weekend, it didn't turn on. I pressed the reset button, changed the batteries, and plugged it into the wall socket, but nothing.
I did a quick online search and found that others have had this same problem, but no consensus as to what caused it or how to fix it.
Any ideas what caused this problem? Is it fixable by me or a repair technician? Or should I just give it a decent burial and buy another radio? (If the latter, donations instead of flowers will be gratefully appreciated.) 8-)
User avatar
Andrew (grayhat)
Posts: 210
Joined: Sat May 28, 2022 5:56 am
Location: JN63pn

Re: What killed my PL-660?

Post by Andrew (grayhat) »

you're not alone :( a number of those relatively "cheap" receivers, seem to be on the same boat; after some time, they start having problems <deep sigh> the times of the Yaesu, JRC, Kenwood, ICOM and other receivers are past, modern ones seem to be designed with a "preprogrammed life length" and this is a really BAD thing
13dka
Posts: 98
Joined: Sat May 28, 2022 4:27 am
Location: On or near a dike

Re: What killed my PL-660?

Post by 13dka »

Maybe there's some useful information in this thread:

https://ham.stackexchange.com/questions ... sun-pl-660
Post Reply